Kurobox NAS-Central Forums

Welcome to the Kuro Community
It is currently Fri Apr 20, 2018 10:39 am

All times are UTC-06:00




Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 16 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Fri Jul 14, 2006 11:24 pm 
Offline

Joined: Fri Jul 14, 2006 10:12 pm
Posts: 5
On that last kurobox sale, I added another kurobox to my collection of kuros/kuroHGs/linkstations - now, my existing kuro/kuroHG have always tended to be prone to the infamous clock slippage, but this was readily addressed via ntpdate & a daily cron without much problem on these.

However, on my new kurobox, the clock slippage has been *enormous* (it just managed to lose 12 hours over 36 hours!). Even running a daily ntpdate & setting up ntpd didn't seem to help. I tried using adjtime.pl to change the tick adjustment & found it failed, seemingly because the calculated value that it tried to apply to tickadj was too large (13349 - tickadj only seems to accept a range between 9000-11000).

I'm a relative newb with Sylver's install (I've previously used setup's based on the standard kuro installs), so it's possible I've mangled something somewhere - but I'm at a loss as to what to try next, to get the darned thing to keep time! If anyone has any ideas, they'll be most welcome!

Cheers, Limey.


Top
   
 Post subject:
PostPosted: Sat Jul 15, 2006 5:00 am 
Offline

Joined: Mon Jan 23, 2006 4:30 pm
Posts: 99
Location: France
dunno if this would help (coz I'm on Gentoo), but I just installed openntpd (a port from OpenBSD's ntpd) and it's dead easy to setup and looks like it is designed to keep the clock in sync all the time, because it's both a ntp server and a ntp client.

(maybe I'm too optimistic, it's a brand new install, but compated to the other ntp client I had, at least this one works ;))


Top
   
 Post subject:
PostPosted: Mon Jul 24, 2006 12:40 pm 
Offline

Joined: Sat Apr 15, 2006 12:14 pm
Posts: 8
I'm seeing the same enormous slippage problem that you are. So if you figure anything out, please post here.

I don't remember seeing this problem when I first got my Kurobox. I noticed it right after installing Sylver's image and getting SlimServer running on it. It could be that I never bothered to look at the time before I made those changes, but I have been considering going back to the original image to see if that fixes the clock problem. Enogh people are using Sylver's image that I doubt that it is causing the problem, but perhaps my installation of SlimServer changed some files? Maybe we both made the same mistake while installing Sylver's image?


Top
   
 Post subject:
PostPosted: Mon Jul 24, 2006 10:46 pm 
Offline

Joined: Fri Jul 14, 2006 10:12 pm
Posts: 5
acknak wrote:
Enogh people are using Sylver's image that I doubt that it is causing the problem, but perhaps my installation of SlimServer changed some files? Maybe we both made the same mistake while installing Sylver's image?


Possibly, though I can't imagine what I could have messed up that would screw up the clock to the point where it loses 10 mins per hour! :shock:
I'm currently using the box to test out some things (like getting AlienBBC to run with slimserver :) ), so I don't really want to swap the drive out & try the standard distro just yet. For now, I've resorted to turning off ntpd & running an *hourly* ntpdate, just so it doesn't get too far off track.

Tallinu's suggestion might be worth a try, if it can be installed on the Sylver distro, but the fact that the timekeeping is already so far off that tickadj can't cope is what really puzzles me - I've never seen that degree of slippage on other boxes. Out of curiousity, if you run adjtime.pl, what did it say the final tick adjustment was?


Top
   
 Post subject:
PostPosted: Wed Jul 26, 2006 5:52 am 
Offline

Joined: Mon Jan 23, 2006 4:30 pm
Posts: 99
Location: France
errr... where do you find this adjtime.pl ?


there is an option in openntpd to set time on startup (regardless of adjustment size, I think)


Top
   
 Post subject:
PostPosted: Wed Jul 26, 2006 10:33 pm 
Offline

Joined: Fri Jul 14, 2006 10:12 pm
Posts: 5
Tallinu wrote:
errr... where do you find this adjtime.pl ?


You can get it from: http://groups.yahoo.com/group/LinkStation_General/files/

It does a quick test of kuro clock time elapsed against the time taken from ntpdate & calculates the appropriate value to apply to tickadj to keep time (unless that value happens to be greater/smaller than the range tickadj will accept :? ).

Tallinu wrote:
there is an option in openntpd to set time on startup (regardless of adjustment size, I think)


I'll download the portable version & take a look.


Top
   
 Post subject:
PostPosted: Thu Jul 27, 2006 4:40 am 
Offline

Joined: Wed Jan 19, 2005 1:36 pm
Posts: 299
It's also in Portage at http://www.gentoo-portage.com/sys-apps/adjtime


Top
   
 Post subject:
PostPosted: Thu Jul 27, 2006 6:10 am 
Offline

Joined: Mon Jan 23, 2006 4:30 pm
Posts: 99
Location: France
thanks


Top
   
PostPosted: Mon Jul 31, 2006 9:58 pm 
Offline

Joined: Sat Apr 15, 2006 12:14 pm
Posts: 8
Well, I reverted back to the original Kuro image and the huge slippage is gone. The only additional packages I've installed are the standard Kuro ones (except for Perl), Perl 5.8.8 and slimserver 6.3.1.

I kicked off ntp and it seems to be working properly. So, I think it's safe to say that the huge slippage problem is not broken hardware.

Unfortunately I can't say what you need to do to fix your install. The things I did this time (which I'm pretty sure I did last time):

1) initially set the clock with 'date'
2) get rid of the calib_time.sh entry from /etc/crontab
3) comment out the whole /etc/timezone file
4) link /etc/localtime to /usr/share/zoneinfo/whereveryouare
5) added an ntpdate call to rc.d


Top
   
 Post subject:
PostPosted: Tue Aug 01, 2006 8:11 am 
Offline

Joined: Sat Apr 15, 2006 12:14 pm
Posts: 8
OK, strike that part about ntp working though. I guess ntp was running but not adjusting the clock. But the drift is definitely back in the acceptable range. adjtime.pl now sets tickadj to 9931 rather than hitting the out-of-range value with 13300.


Top
   
 Post subject:
PostPosted: Tue Aug 01, 2006 2:04 pm 
Offline

Joined: Fri Jul 14, 2006 10:12 pm
Posts: 5
acknak wrote:
OK, strike that part about ntp working though. I guess ntp was running but not adjusting the clock. But the drift is definitely back in the acceptable range. adjtime.pl now sets tickadj to 9931 rather than hitting the out-of-range value with 13300.


Interesting. Were you running the 2.6 non-HG kernal before, or the 2.4 non-HG kernal?
I'm wondering if there is something in the kernal code that assumes the faster 266Mhz clock speed of the HG box is present...


Top
   
 Post subject: Yes, I think that's it.
PostPosted: Wed Aug 02, 2006 6:16 pm 
Offline

Joined: Sat Apr 15, 2006 12:14 pm
Posts: 8
Yes, I was running 2.6.15.6 before, and I am non-HG. The faster clock idea makes sense to me, and the math even works out (I think):

266 MHz/ 200 MHz * 10000 = 13300

That's pretty much the tick value that adjtime chose for me.


Top
   
 Post subject:
PostPosted: Thu Aug 03, 2006 1:27 pm 
Offline

Joined: Mon Jan 23, 2006 4:30 pm
Posts: 99
Location: France
on my Kuro HG running stock kernel, the adjusted tick is around 9987.

it's an 8s drift in 48 hours, instead of much more :)


Top
   
 Post subject:
PostPosted: Fri Aug 04, 2006 2:29 am 
Offline

Joined: Fri Jul 14, 2006 10:12 pm
Posts: 5
Tallinu wrote:
on my Kuro HG running stock kernel, the adjusted tick is around 9987.

it's an 8s drift in 48 hours, instead of much more :)


Yep, that's back in the range I usually see on these boxes.

I did wonder if I somehow managed to install the kuroHG 2.6 kernel patch instead of the non-HG one, but as far as I can tell, that isn't the case - when I SSH in, the box reports "Linux (none) 2.6.15.6-kurobox". It does look as if there's something in the kernel thats assuming the 266Mhz clock is in use - but its still odd that this hasn't been widely reported by users of the 200Mhz box (I'm not ruling out my having screwed something up, yet! :D )


Top
   
 Post subject:
PostPosted: Fri Aug 04, 2006 12:00 pm 
Offline

Joined: Sun Jun 12, 2005 1:31 am
Posts: 220
There was one version of a kernel patch that was not correct and did not handle the kuro system clock correctly.

A later patch was released that corrected it but which patch is being used I have no idea.


Top
   
Display posts from previous:  Sort by  
Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 16 posts ]  Go to page 1 2 Next

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited