Kurobox NAS-Central Forums

Welcome to the Kuro Community
It is currently Mon Jun 25, 2018 11:35 am

All times are UTC-06:00




Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: USB
PostPosted: Tue Mar 07, 2006 12:25 pm 
Offline

Joined: Fri Mar 03, 2006 6:55 am
Posts: 19
Anyone tried to use the USB on the FC4 image yet? I need to try to get a external drive on one(as well as maybe a usb key) and a laser printer on the other. But before I spend to much time and tear apart my current network, it would help to know if anyone knows if it is working or not. :) Thanks

_________________
----------------------------------------------
Brand new Kuro still in the box!


Top
   
 Post subject: USB
PostPosted: Tue Mar 07, 2006 6:47 pm 
Offline

Joined: Fri Mar 03, 2006 6:55 am
Posts: 19
Anyone having issues with USB. I haven't tried to use much yet, but I can't get either one of my USB keys to load. The system sees them, and seems to be ok, but I get the following output when I try to mount it:

dmesg:

usb-storage: waiting for device to settle before scanning
Vendor: Model: USB DISK 2.0 Rev: PMAP
Type: Direct-Access ANSI SCSI revision: 00
SCSI device sda: 246272 512-byte hdwr sectors (126 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 246272 512-byte hdwr sectors (126 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
sda: sda1
sd 1:0:0:0: Attached scsi removable disk sda
sd 1:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
Unable to load NLS charset cp437
FAT: codepage cp437 not found

mount:
[root@localhost ~]# mount /dev/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so



Well I now know what this is and why I am getting it. I just have to take a couple hours and rebuild the kernel to include these.

_________________
----------------------------------------------

Brand new Kuro still in the box!


Top
   
 Post subject: Usb key working now.
PostPosted: Thu Mar 09, 2006 6:04 pm 
Offline

Joined: Fri Mar 03, 2006 6:55 am
Posts: 19
Got the USB keys working now. Just edited the kernel .config and uncommented nls_cp437 and nsl_iso8859_1. Change both of those to modules. Compile, and copy the .ko to the /lib/modules/2.6.15.1/kernel/fs/nls directory. run depmod and your done.

_________________
----------------------------------------------

Brand new Kuro still in the box!


Top
   
 Post subject:
PostPosted: Mon May 01, 2006 5:29 pm 
Offline

Joined: Thu Oct 07, 2004 4:58 pm
Posts: 17
Location: Seattle, WA
KuroNoob,

Did you get hotplugging to work with USB. I followed your advise and added nls_cp437 and nsl_iso8859_1 as modules to my (FC4) kernel. I can use the USB drives (flash and HDD enclosure), but I have to mount them manually. I believe the 2.6.15.1 kernel has the hotplugging capability (hald events, etc) but I don't know if I have the moudules mis-configured or sometihing?

-- Mig


Top
   
Display posts from previous:  Sort by  
Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited