Kurobox NAS-Central Forums

Welcome to the Kuro Community
It is currently Sun Jun 24, 2018 11:50 pm

All times are UTC-06:00

Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 20 posts ]  Go to page Previous 1 2
Author Message
 Post subject:
PostPosted: Fri Sep 07, 2007 2:14 am 

Joined: Fri Oct 29, 2004 6:00 am
Posts: 91
Location: UK
ja2robin wrote:
I was wrong about the apostrophes, you do NOT need them on this command:
setenv bootargs $(bootargs_base) $(bootargs_root) $(buffalo_ver)

I think the apostrophes keep the "${blah}" parameters 'special'.

So if you don't use apostrophes, the parameters will be evaluated before the bootargs parameter is set, and fixed thereafter. With the apostrophes, the parameters are stored, so will be evaluated afresh each time 'bootargs' is evaluated.


 Post subject: Re: SOLVED.
PostPosted: Fri Sep 07, 2007 3:37 am 

Joined: Thu Jun 07, 2007 11:42 am
Posts: 29
ja2robin wrote:
Hi guys,

put the hard drive back into the Kurobox Pro, booted, copied the appropriate files to /mtd device/ and then pressed the red button. This time, I could hear the hard drive doing lots of churning, which was different then my last several attempts. After about 5 minutes the info light stopped flashing, so I rebooted.

After reboot I had a Debian login prompt.

I think I can tell you what happened. Even though it's a pain. Using this method if the kurobox detects that the drive is already partitioned with XFS formatted partions, it stops,

http://www.kurobox.com/downloads/Kurobo ... ations.pdf

check pages 12 and 20

 Post subject:
PostPosted: Sat Sep 08, 2007 8:34 pm 

Joined: Fri Aug 24, 2007 8:13 pm
Posts: 9
Lardmonster: I agree with your assessment on the apostrophes. I was convinced that leaving these parameters 'dynamic' instead of 'fixed' would be better, but it just wasn't booting when I had left them dynamic. Making the fixed worked for me.

ramuk: I checked that pdf you referenced:

- If the internal HDD (/dev/sda) is already formatted in xfs format, formatting will not be performed. However, if you set force_format=yes in /etc/melco/info, you can format irrespective of whether the HDD is currently formatted in xfs format or not.

- If the internal HDD (/dev/sda) already has partitions, those partitions will be deleted.

I did encounter the case once where I pressed the red button when I knew the drive was formatted but I got some sort of error sounding beep and the serial interface spit out "the drive is already formatted!" This is consistent with the statements above.

But with the partitions deleted (via fdisk), it looked like the button press would create the 4 partitions and then hang for some reason. Maybe creating the exact same partitions that I just deleted made the drive appear as suddenly back the way it was before I deleted the partitions. That is possible I guess. Then maybe it saw some files on the drive it didn't like and just stopped. Maybe I should have formatted the drive, then deleted the partitions. I bet that might have also worked.


 Post subject:
PostPosted: Thu Oct 11, 2007 6:07 pm 

Joined: Wed Sep 26, 2007 6:12 pm
Posts: 14
I think this thread should be sticked.

Is there any linux alternatives for kill disk?
I tried: dd if=/dev/zero of=/dev/sda without sucess;

 Post subject: Re: SOLVED.
PostPosted: Thu Nov 01, 2007 11:46 pm 

Joined: Tue Mar 06, 2007 4:00 pm
Posts: 3
ja2robin wrote:
To solve the problem mentioned in the post directly above I needed to remove the hard drive and drop it into my Windows PC. I downloaded a program called Killdisk (http://www.killdisk.com/) and used it to write all 00's to the drive.

Hi... you gave me idea... I previously had same experience as yours.. then I read about "killdisk", however, I use Seatools (http://www.seagate.com/www/en-us/suppor ... /seatools/) because my harddisk is Seagate product :) to zero out the drive.

Only after that then reset button works...

Thanks much for your share...

Display posts from previous:  Sort by  
Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 20 posts ]  Go to page Previous 1 2

All times are UTC-06:00

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited