Kurobox NAS-Central Forums

Welcome to the Kuro Community
It is currently Sun Dec 17, 2017 5:12 pm

All times are UTC-06:00




Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 23 posts ]  Go to page Previous 1 2
Author Message
 Post subject:
PostPosted: Thu Feb 07, 2008 7:55 am 
Offline

Joined: Thu May 25, 2006 7:20 am
Posts: 43
Location: Sydney, Australia
Hmmm I thought this forum was locked? guess not? ;)

I ended up flashing with a precompiled UBoot 1.2 found here:
http://downloads.nas-central.org/LSHG_P ... 2.0-r2.bin

Bit of guess work, had to change a few Uboot env vars so it could find my Gentoo Kernel apart from that it was pretty straight forward.


Top
   
 Post subject:
PostPosted: Wed Oct 08, 2008 3:19 pm 
Offline

Joined: Thu May 25, 2006 7:20 am
Posts: 43
Location: Sydney, Australia
Hi Peach,

From memory I didn't modify any scripts. just flashed the binary in and changed the UBoot env vars.

Apparently this is a bit unsafe but worked on two kuro HGs. (Plus I have JTAG)

I wrote down the steps I took, but i'm on the road at the moment. When I get back home I will dig them out for you.

:wink:
Cheers,
Stonie.


Top
   
 Post subject:
PostPosted: Thu Oct 09, 2008 8:31 am 
Offline

Joined: Thu May 25, 2006 7:20 am
Posts: 43
Location: Sydney, Australia
Try this at your own risk :wink:

I ran:

Code:
dd if=u-boot-lsppchg-flash-1.2.0-r2.bin of=/dev/fl2 bs=1k

----
174+1 records in
174+1 records out



Setup a net console (netcat) on your pc. (you might need to change the ip)

Code:
nc -u -p 6666 -v -v 192.168.11.150 6666

-output:
1.2.3.4: inverse host lookup failed:
(UNKNOWN) [1.2.3.4] 6666 (?) open


Reboot your kuro... When the kuro comes back up you should see some output in your net console, However the procompilled UBoot binary we used is looking for the incorrect image name.
*Settings below are corrrect for the gentoo image*

We need to halt the uboot process and change some environment vars.

Press s to stop the uboot process.

Code:
=> printenv hdfile
hdfile=boot/uImage

=> setenv hdfile boot/vmlinux.UBoot
setenv hdfile boot/vmlinux.UBoot

=> saveenv

=> boot


Seems to take a while to finaly come up, go and get a coffee or a beer :wink:


Top
   
 Post subject:
PostPosted: Thu Oct 09, 2008 9:12 am 
Offline

Joined: Thu May 25, 2006 7:20 am
Posts: 43
Location: Sydney, Australia
yep, well spotted, I flashed a couple with this method. both 2.4. stock HG's.

As far as I can tell.. in this case bricking is the result of a failed flash. However you can save it using JTAG. (never needed to do this myself)

Good luck!

Cheers,
Stonie.


Top
   
 Post subject:
PostPosted: Fri Oct 10, 2008 4:28 pm 
Offline

Joined: Thu May 25, 2006 7:20 am
Posts: 43
Location: Sydney, Australia
You can also try:

BTW the new forum: http://buffalo.nas-central.org/forums/index.php

Seems to be the current forum, with fresh info. I think this forum is here more for historical reasons? the other one has a lot more traffic.

:wink:
Glad you got your box sorted.

Cheers,
Stonie.


Top
   
Display posts from previous:  Sort by  
Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 23 posts ]  Go to page Previous 1 2

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited