Kurobox NAS-Central Forums

Welcome to the Kuro Community
It is currently Sun Jun 24, 2018 8:10 pm

All times are UTC-06:00




Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 1 post ] 
Author Message
PostPosted: Thu Jul 26, 2007 1:41 pm 
Offline

Joined: Thu Jul 26, 2007 12:36 pm
Posts: 1
I would like to get the stock 2.6.20 kernel running on my kurobox-hg. I have been following the instructions on http://www.kurobox.com/mwiki/index.php/ ... .6_kernels. However, when I get to the part which verifies that U-Boot from RAM works booting the old 2.4.x kernel from flash, I'm unsure that I'm actually booting from U-Boot. It always comes back up using the 2.4.x kernel, but how can I be sure this is U-Boot booting it and not the Kuro failing and restarting using it's normal process?

I thought that I'd try tweaking the kernel parameters in U-Boot, then I could look at the dmesg output once the 2.4.x kernel had booted. I have tried putting in the debug parameter, even setting the root=/dev/sda1 and root=/dev/hda2 (to force it to fail), but it always works and always the dmesg log shows the kernel command line as root=/dev/hda1. Why is this? Is U-Boot actually booting the kernel, or is it falling back to the standard process? Or is it working but ignoring the parameters? How can I find out before I proceed with the flash?

Any suggestions would be welcome!

Thanks

_jpg_


Top
   
Display posts from previous:  Sort by  
Forum locked  This topic is locked, you cannot edit posts or make further replies.  [ 1 post ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited